summaryrefslogtreecommitdiff
path: root/grc/src/platforms/base/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'grc/src/platforms/base/Makefile.am')
-rw-r--r--grc/src/platforms/base/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/grc/src/platforms/base/Makefile.am b/grc/src/platforms/base/Makefile.am
new file mode 100644
index 000000000..dca53b8b5
--- /dev/null
+++ b/grc/src/platforms/base/Makefile.am
@@ -0,0 +1,47 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/grc/Makefile.inc
+
+ourpythondir = $(grc_src_prefix)/platforms/base
+
+ourpython_PYTHON = \
+ Block.py \
+ Connection.py \
+ Constants.py \
+ Element.py \
+ FlowGraph.py \
+ Param.py \
+ Platform.py \
+ Port.py \
+ __init__.py
+
+BUILT_SOURCES = Constants.py
+
+Constants.py: Makefile $(srcdir)/Constants.py.in
+ sed \
+ -e 's|@VERSION[@]|$(VERSION)|g' \
+ -e 's|@datadir[@]|$(grc_base_data_dir)|g' \
+ $(srcdir)/Constants.py.in > $@
+
+EXTRA_DIST = Constants.py.in
+
+MOSTLYCLEANFILES = $(BUILT_SOURCES)