summaryrefslogtreecommitdiff
path: root/grc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'grc/Makefile.am')
-rw-r--r--grc/Makefile.am13
1 files changed, 4 insertions, 9 deletions
diff --git a/grc/Makefile.am b/grc/Makefile.am
index 2b5dc730b..9d473b4d3 100644
--- a/grc/Makefile.am
+++ b/grc/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2008, 2009 Free Software Foundation, Inc.
+# Copyright 2008-2011 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -25,29 +25,24 @@ if PYTHON
SUBDIRS = \
base \
blocks \
+ freedesktop \
grc_gnuradio \
gui \
python \
scripts
-## append freedesktop to the list of subdirs when xdg utils are present
-if XDG_UTILS
-SUBDIRS += freedesktop
-endif
-
ourpythondir = $(pkgpythondir)/grc
ourpython_PYTHON = __init__.py
etcdir = $(gr_prefsdir)
dist_etc_DATA = grc.conf
-EXTRA_DIST = $(srcdir)/grc.conf.in
+EXTRA_DIST += $(srcdir)/grc.conf.in
-BUILT_SOURCES = grc.conf
+BUILT_SOURCES += grc.conf
grc.conf: $(srcdir)/grc.conf.in Makefile
sed \
- -e 's|@pythonw[@]|$(PYTHONW)|g' \
-e 's|@blocksdir[@]|$(grc_blocksdir)|g' \
-e 's|@docdir[@]|$(gr_docdir)|g' \
$< > $@