summaryrefslogtreecommitdiff
path: root/gr-wxgui/grc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-wxgui/grc/CMakeLists.txt')
-rw-r--r--gr-wxgui/grc/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/gr-wxgui/grc/CMakeLists.txt b/gr-wxgui/grc/CMakeLists.txt
new file mode 100644
index 000000000..c39b5cfbe
--- /dev/null
+++ b/gr-wxgui/grc/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+FILE(GLOB xml_files "*.xml")
+INSTALL(FILES ${xml_files} DESTINATION ${GRC_BLOCKS_DIR} COMPONENT "wxgui")
+
+########################################################################
+#The wxgui module contains a top_block + wxgui frame.
+########################################################################
+INCLUDE(GrPython)
+
+GR_PYTHON_INSTALL(
+ FILES
+ __init__.py
+ panel.py
+ top_block_gui.py
+ DESTINATION ${GR_PYTHON_DIR}/grc_gnuradio/wxgui
+ COMPONENT "wxgui"
+)