summaryrefslogtreecommitdiff
path: root/gr-vocoder/include/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-vocoder/include/CMakeLists.txt')
-rw-r--r--gr-vocoder/include/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/gr-vocoder/include/CMakeLists.txt b/gr-vocoder/include/CMakeLists.txt
new file mode 100644
index 000000000..23099f59e
--- /dev/null
+++ b/gr-vocoder/include/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Install header files
+########################################################################
+install(FILES
+ vocoder_api.h
+ vocoder_alaw_decode_bs.h
+ vocoder_alaw_encode_sb.h
+ vocoder_codec2_decode_ps.h
+ vocoder_codec2_encode_sp.h
+ vocoder_cvsd_decode_bs.h
+ vocoder_cvsd_encode_sb.h
+ vocoder_g721_decode_bs.h
+ vocoder_g721_encode_sb.h
+ vocoder_g723_24_decode_bs.h
+ vocoder_g723_24_encode_sb.h
+ vocoder_g723_40_decode_bs.h
+ vocoder_g723_40_encode_sb.h
+ vocoder_gsm_fr_decode_ps.h
+ vocoder_gsm_fr_encode_sp.h
+ vocoder_ulaw_decode_bs.h
+ vocoder_ulaw_encode_sb.h
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio
+ COMPONENT "vocoder_devel"
+)