summaryrefslogtreecommitdiff
path: root/gr-video-sdl/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-video-sdl/src/Makefile.am')
-rw-r--r--gr-video-sdl/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/gr-video-sdl/src/Makefile.am b/gr-video-sdl/src/Makefile.am
index 496671bea..e52e23632 100644
--- a/gr-video-sdl/src/Makefile.am
+++ b/gr-video-sdl/src/Makefile.am
@@ -56,6 +56,18 @@ libgnuradio_video_sdl_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
TOP_SWIG_IFILES = \
video_sdl.i
+TOP_SWIG_DOC_IFILES = \
+ video_sdl_swig_doc.i
+
+BUILT_SOURCES += \
+ $(TOP_SWIG_DOC_IFILES)
+
+EXTRA_DIST += \
+ $(TOP_SWIG_DOC_IFILES)
+
+$(TOP_SWIG_DOC_IFILES):
+ `echo "" > $@`
+
# Install so that they end up available as:
# import gnuradio.video_sdl
# This ends up at:
@@ -67,6 +79,9 @@ video_sdl_pythondir_category = \
video_sdl_la_swig_libadd = \
libgnuradio-video-sdl.la
+video_sdl_swiginclude_headers = \
+ $(TOP_SWIG_DOC_IFILES)
+
if PYTHON
TESTS += run_tests
endif