summaryrefslogtreecommitdiff
path: root/gr-uhd/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-uhd/swig/Makefile.am')
-rw-r--r--gr-uhd/swig/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/gr-uhd/swig/Makefile.am b/gr-uhd/swig/Makefile.am
index da62e0552..ee868b15f 100644
--- a/gr-uhd/swig/Makefile.am
+++ b/gr-uhd/swig/Makefile.am
@@ -54,12 +54,12 @@ TOP_SWIG_DOC_IFILES = \
BUILT_SOURCES += \
$(TOP_SWIG_DOC_IFILES)
+EXTRA_DIST += \
+ $(TOP_SWIG_DOC_IFILES)
+
$(TOP_SWIG_DOC_IFILES):
`echo "" > $@`
-install-data-local:
- cp -p $(TOP_SWIG_DOC_IFILES) $(swigincludedir)
-
# Install so that they end up available as:
# import gnuradio.uhd
# This ends up at:
@@ -76,7 +76,8 @@ uhd_swig_python = \
__init__.py
# additional SWIG files to be installed
-uhd_swig_swiginclude_headers =
+uhd_swig_swiginclude_headers = \
+ $(TOP_SWIG_DOC_IFILES)
uhd_swig_swig_args = $(UHD_CPPFLAGS)