summaryrefslogtreecommitdiff
path: root/gr-uhd/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-uhd/swig/Makefile.am')
-rw-r--r--gr-uhd/swig/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/gr-uhd/swig/Makefile.am b/gr-uhd/swig/Makefile.am
index b201f676b..3b7b3cc60 100644
--- a/gr-uhd/swig/Makefile.am
+++ b/gr-uhd/swig/Makefile.am
@@ -20,6 +20,9 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+EXTRA_DIST += $(nobase_guile_DATA)
AM_CPPFLAGS = \
$(STD_DEFINES_AND_INCLUDES) \
@@ -29,7 +32,11 @@ AM_CPPFLAGS = \
uhd_swig_swig_args = $(UHD_CPPFLAGS)
-if PYTHON
+if GUILE
+nobase_guile_DATA = \
+ gnuradio/uhd.scm
+endif
+
# ----------------------------------------------------------------
# The SWIG library
# TESTS = run_tests
@@ -55,11 +62,6 @@ uhd_swig_python = \
# additional SWIG files to be installed
uhd_swig_swiginclude_headers =
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-endif
+uhd_swig_swig_args = \
+ $(UHD_CFLAGS) \
+ -I$(top_srcdir)/gr-uhd/lib