summaryrefslogtreecommitdiff
path: root/gr-uhd/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-uhd/lib/Makefile.am')
-rw-r--r--gr-uhd/lib/Makefile.am45
1 files changed, 45 insertions, 0 deletions
diff --git a/gr-uhd/lib/Makefile.am b/gr-uhd/lib/Makefile.am
new file mode 100644
index 000000000..d4363406b
--- /dev/null
+++ b/gr-uhd/lib/Makefile.am
@@ -0,0 +1,45 @@
+#
+# Copyright 2010 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = \
+ $(STD_DEFINES_AND_INCLUDES) \
+ $(WITH_INCLUDES) \
+ $(UHD_CFLAGS)
+
+lib_LTLIBRARIES = libgnuradio-uhd.la
+
+libgnuradio_uhd_la_SOURCES = \
+ utils.cc \
+ uhd_simple_source.cc \
+ uhd_simple_sink.cc
+
+libgnuradio_uhd_la_LIBADD = \
+ $(GNURADIO_CORE_LA) \
+ $(UHD_LIBS)
+
+grinclude_HEADERS = \
+ uhd_simple_source.h \
+ uhd_simple_sink.h
+
+noinst_HEADERS = \
+ utils.h