summaryrefslogtreecommitdiff
path: root/gr-uhd/examples/grc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-uhd/examples/grc/CMakeLists.txt')
-rw-r--r--gr-uhd/examples/grc/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/gr-uhd/examples/grc/CMakeLists.txt b/gr-uhd/examples/grc/CMakeLists.txt
new file mode 100644
index 000000000..06c233d45
--- /dev/null
+++ b/gr-uhd/examples/grc/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+install(
+ FILES
+ uhd_const_wave.grc
+ uhd_dpsk_mod.grc
+ uhd_fft.grc
+ uhd_rx_dpsk.grc
+ uhd_two_tone_loopback.grc
+ uhd_tx_dpsk.grc
+ uhd_wbfm_receive.grc
+ DESTINATION ${GR_PKG_UHD_EXAMPLES_DIR}
+ COMPONENT "uhd_python"
+)