summaryrefslogtreecommitdiff
path: root/gr-trellis/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-trellis/src/lib/Makefile.am')
-rw-r--r--gr-trellis/src/lib/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/gr-trellis/src/lib/Makefile.am b/gr-trellis/src/lib/Makefile.am
index ae7f21f56..795ac28b4 100644
--- a/gr-trellis/src/lib/Makefile.am
+++ b/gr-trellis/src/lib/Makefile.am
@@ -29,7 +29,8 @@ EXTRA_DIST += \
trellis.test
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES) \
+ -I$(abs_top_srcdir)/gr-digital/lib -I/home
# ----------------------------------------------------------------
# these scripts generate trellis codes from template files
@@ -81,13 +82,13 @@ grinclude_HEADERS = \
quicksort_index.h \
base.h \
interleaver.h \
- metric_type.h \
calc_metric.h \
core_algorithms.h \
trellis_permutation.h \
siso_type.h \
trellis_siso_f.h \
trellis_siso_combined_f.h \
+ trellis_constellation_metrics_cf.h \
$(GENERATED_H)
lib_LTLIBRARIES = libgnuradio-trellis.la
@@ -102,6 +103,7 @@ libgnuradio_trellis_la_SOURCES = \
trellis_permutation.cc \
trellis_siso_f.cc \
trellis_siso_combined_f.cc \
+ trellis_constellation_metrics_cf.cc \
$(GENERATED_CC)
libgnuradio_trellis_la_LIBADD = \
@@ -136,6 +138,7 @@ trellis_swiginclude_headers = \
trellis_permutation.i \
trellis_siso_f.i \
trellis_siso_combined_f.i \
+ trellis_constellation_metrics_cf.i \
trellis_generated.i
# Do creation and inclusion of other Makefiles last
@@ -157,6 +160,11 @@ include $(top_srcdir)/Makefile.par.gen
BUILT_SOURCES += $(python_built_sources)
+# Location of non-standard SWIG interface files
+trellis_swig_args = \
+ -I$(top_srcdir)/gr-digital/lib \
+ -I$(top_srcdir)/gr-digital/swig
+
if GUILE
TESTS += run_guile_tests
endif