summaryrefslogtreecommitdiff
path: root/gr-trellis/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-trellis/src/lib/Makefile.am')
-rw-r--r--gr-trellis/src/lib/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/gr-trellis/src/lib/Makefile.am b/gr-trellis/src/lib/Makefile.am
index 8f703c92a..435a093d6 100644
--- a/gr-trellis/src/lib/Makefile.am
+++ b/gr-trellis/src/lib/Makefile.am
@@ -29,7 +29,9 @@ EXTRA_DIST += \
trellis.test
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
+ $(GR_DIGITAL_INCLUDES) \
+ $(WITH_INCLUDES)
# ----------------------------------------------------------------
# these scripts generate trellis codes from template files
@@ -80,17 +82,18 @@ EXTRA_DIST += \
# These headers get installed in ${prefix}/include/gnuradio
grinclude_HEADERS = \
+ trellis_api.h \
fsm.h \
quicksort_index.h \
base.h \
interleaver.h \
- metric_type.h \
calc_metric.h \
core_algorithms.h \
trellis_permutation.h \
siso_type.h \
trellis_siso_f.h \
trellis_siso_combined_f.h \
+ trellis_constellation_metrics_cf.h \
$(GENERATED_H)
lib_LTLIBRARIES = libgnuradio-trellis.la
@@ -105,6 +108,7 @@ libgnuradio_trellis_la_SOURCES = \
trellis_permutation.cc \
trellis_siso_f.cc \
trellis_siso_combined_f.cc \
+ trellis_constellation_metrics_cf.cc \
$(GENERATED_CC)
libgnuradio_trellis_la_LIBADD = \
@@ -139,6 +143,7 @@ trellis_swiginclude_headers = \
trellis_permutation.i \
trellis_siso_f.i \
trellis_siso_combined_f.i \
+ trellis_constellation_metrics_cf.i \
trellis_generated.i
# Do creation and inclusion of other Makefiles last
@@ -160,6 +165,10 @@ include $(top_srcdir)/Makefile.par.gen
BUILT_SOURCES += $(python_built_sources)
+# Location of non-standard SWIG interface files
+trellis_swig_args = \
+ $(GR_DIGITAL_INCLUDES)
+
if GUILE
TESTS += run_guile_tests
endif