summaryrefslogtreecommitdiff
path: root/gr-pager/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-pager/swig/Makefile.am')
-rw-r--r--gr-pager/swig/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/gr-pager/swig/Makefile.am b/gr-pager/swig/Makefile.am
index c59bdb0f2..fe22753e3 100644
--- a/gr-pager/swig/Makefile.am
+++ b/gr-pager/swig/Makefile.am
@@ -20,6 +20,9 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+TESTS =
AM_CPPFLAGS = \
-I$(top_srcdir)/gr-pager/lib \
@@ -27,6 +30,9 @@ AM_CPPFLAGS = \
$(PYTHON_CPPFLAGS) \
$(WITH_INCLUDES)
+nobase_guile_DATA = \
+ gnuradio/pager.scm
+
##############################
# SWIG interface and library
TOP_SWIG_IFILES = \
@@ -51,10 +57,13 @@ pager_swig_swiginclude_headers = \
pager_flex_sync.i \
pager_slicer_fb.i
-include $(top_srcdir)/Makefile.swig
# add some of the variables generated inside the Makefile.swig.gen
BUILT_SOURCES = $(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+
+if GUILE
+TESTS += run_guile_tests
+endif \ No newline at end of file