summaryrefslogtreecommitdiff
path: root/gr-noaa/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-noaa/swig/Makefile.am')
-rw-r--r--gr-noaa/swig/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/gr-noaa/swig/Makefile.am b/gr-noaa/swig/Makefile.am
index 410b23fe6..51a72ffb6 100644
--- a/gr-noaa/swig/Makefile.am
+++ b/gr-noaa/swig/Makefile.am
@@ -20,6 +20,14 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+TESTS =
+
+if GUILE
+nobase_guile_DATA = gnuradio/noaa.scm
+endif
+
AM_CPPFLAGS = \
-I$(top_srcdir)/gr-noaa/lib \
@@ -27,7 +35,6 @@ AM_CPPFLAGS = \
$(PYTHON_CPPFLAGS) \
$(WITH_INCLUDES)
-if PYTHON
# ----------------------------------------------------------------
# The SWIG library
# TESTS = run_tests
@@ -56,11 +63,12 @@ noaa_swig_swiginclude_headers = \
noaa_hrpt_deframer.i \
noaa_hrpt_pll_cf.i
-include $(top_srcdir)/Makefile.swig
-
# add some of the variables generated inside the Makefile.swig.gen
BUILT_SOURCES = $(swig_built_sources)
# Do not distribute the output of SWIG
no_dist_files = $(swig_built_sources)
+
+if GUILE
+TESTS += run_guile_tests
endif