summaryrefslogtreecommitdiff
path: root/gr-noaa/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-noaa/examples/CMakeLists.txt')
-rw-r--r--gr-noaa/examples/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/gr-noaa/examples/CMakeLists.txt b/gr-noaa/examples/CMakeLists.txt
new file mode 100644
index 000000000..233f0ee5f
--- /dev/null
+++ b/gr-noaa/examples/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+include(GrPython)
+
+GR_PYTHON_INSTALL(
+ PROGRAMS
+ hrpt_decode.py
+ hrpt_demod.py
+ file_rx_hrpt.py
+ usrp_rx_hrpt.py
+ usrp_rx_hrpt_nogui.py
+ DESTINATION ${GR_RUNTIME_DIR}
+ COMPONENT "noaa_python"
+)