summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-howto-write-a-block/swig/Makefile.am')
-rw-r--r--gr-howto-write-a-block/swig/Makefile.am37
1 files changed, 26 insertions, 11 deletions
diff --git a/gr-howto-write-a-block/swig/Makefile.am b/gr-howto-write-a-block/swig/Makefile.am
index 4737ad619..17c4334f6 100644
--- a/gr-howto-write-a-block/swig/Makefile.am
+++ b/gr-howto-write-a-block/swig/Makefile.am
@@ -20,8 +20,19 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
+
+CLEANFILES = python/*.cc python/*.h python/*.d
+if GUILE
+CLEANFILES += guile/*.cc gnuradio/*.scm guile/*.d
+endif
-AM_CPPFLAGS += -I$(top_srcdir)/lib
+AM_CPPFLAGS += -I$(top_srcdir)/lib
+
+swig_built_sources =
if PYTHON
###################################
@@ -34,21 +45,25 @@ TOP_SWIG_IFILES = \
# import howto
# This ends up at:
# ${prefix}/lib/python${python_version}/site-packages/$(modname)
-
howto_la_swig_libadd = \
$(top_builddir)/lib/libgnuradio-howto.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-
# additional SWIG files to be installed
-howto_swiginclude_headers = \
+aqhowto_swiginclude_headers = \
howto_square_ff.i \
howto_square2_ff.i
+EXTRA_DIST = $(aqhowto_swiginclude_headers)
+
+PYTHON_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(subst .i,.py,$(HFILE)))
+swig_built_sources += $(PYTHON_GEN)
endif
+
+if GUILE
+GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,gnuradio/%.scm,$(HFILE)))
+swig_built_sources += $(GUILE_GEN)
+endif
+
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+