summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/swig/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-howto-write-a-block/swig/Makefile.am')
-rw-r--r--gr-howto-write-a-block/swig/Makefile.am30
1 files changed, 17 insertions, 13 deletions
diff --git a/gr-howto-write-a-block/swig/Makefile.am b/gr-howto-write-a-block/swig/Makefile.am
index 4737ad619..326004235 100644
--- a/gr-howto-write-a-block/swig/Makefile.am
+++ b/gr-howto-write-a-block/swig/Makefile.am
@@ -20,35 +20,39 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+noinst_GUILE = howto.test
-AM_CPPFLAGS += -I$(top_srcdir)/lib
+AM_CPPFLAGS += -I$(top_srcdir)/lib
-if PYTHON
###################################
-# SWIG Python interface and library
+# SWIG interfaces and libraries
TOP_SWIG_IFILES = \
- howto.i
+ howto_swig.i
# Install so that they end up available as:
# import howto
# This ends up at:
# ${prefix}/lib/python${python_version}/site-packages/$(modname)
+howto_swig_pythondir_category = $(modname)
-howto_la_swig_libadd = \
+# additional libraries for linking with the SWIG-generated library
+howto_swig_la_swig_libadd = \
$(top_builddir)/lib/libgnuradio-howto.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-
# additional SWIG files to be installed
howto_swiginclude_headers = \
howto_square_ff.i \
howto_square2_ff.i
+EXTRA_DIST = $(howto_swiginclude_headers)
+
+if GUILE
+TESTS = run_guile_tests
+nobase_guile_DATA = \
+ gnuradio/howto_swig.scm
endif
+
+EXTRA_DIST += $(nobase_guile_DATA)