summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-howto-write-a-block/lib/Makefile.am')
-rw-r--r--gr-howto-write-a-block/lib/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/gr-howto-write-a-block/lib/Makefile.am b/gr-howto-write-a-block/lib/Makefile.am
index 336cb8a20..2e76ee453 100644
--- a/gr-howto-write-a-block/lib/Makefile.am
+++ b/gr-howto-write-a-block/lib/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+# Copyright 2004,2005,2006,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -28,21 +28,21 @@ TESTS = test_all
# howto C++ library: libgnuradio-howto.so
# ----------------------------------------------------------------
-# C/C++ headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS = \
- howto_square_ff.h \
+# C/C++ headers get installed in ${prefix}/include/$(modname)
+modinclude_HEADERS = \
+ howto_square_ff.h \
howto_square2_ff.h
lib_LTLIBRARIES = libgnuradio-howto.la
-libgnuradio_howto_la_SOURCES = \
- howto_square_ff.cc \
+libgnuradio_howto_la_SOURCES = \
+ howto_square_ff.cc \
howto_square2_ff.cc
-libgnuradio_howto_la_LIBADD = \
+libgnuradio_howto_la_LIBADD = \
$(GNURADIO_CORE_LA)
-libgnuradio_howto_la_LDFLAGS = \
+libgnuradio_howto_la_LDFLAGS = \
$(NO_UNDEFINED)
# ----------------------------------------------------------------
@@ -51,23 +51,23 @@ libgnuradio_howto_la_LDFLAGS = \
noinst_LTLIBRARIES = libgnuradio-howto-qa.la
-libgnuradio_howto_qa_la_SOURCES = \
- qa_howto.cc \
- qa_howto_square_ff.cc \
+libgnuradio_howto_qa_la_SOURCES = \
+ qa_howto.cc \
+ qa_howto_square_ff.cc \
qa_howto_square2_ff.cc
libgnuradio_howto_qa_la_LDFLAGS = $(NO_UNDEFINED) -version-info 0:0:0
-libgnuradio_howto_qa_la_LIBADD = \
- libgnuradio-howto.la \
+libgnuradio_howto_qa_la_LIBADD = \
+ libgnuradio-howto.la \
$(CPPUNIT_LIBS)
# ----------------------------------------------------------------
# headers that don't get installed
# ----------------------------------------------------------------
-noinst_HEADERS = \
- qa_howto.h \
- qa_howto_square_ff.h \
+noinst_HEADERS = \
+ qa_howto.h \
+ qa_howto_square_ff.h \
qa_howto_square2_ff.h
# ----------------------------------------------------------------