summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block-cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-howto-write-a-block-cmake/CMakeLists.txt')
-rw-r--r--gr-howto-write-a-block-cmake/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/gr-howto-write-a-block-cmake/CMakeLists.txt b/gr-howto-write-a-block-cmake/CMakeLists.txt
index 9d2d18258..58285ae8f 100644
--- a/gr-howto-write-a-block-cmake/CMakeLists.txt
+++ b/gr-howto-write-a-block-cmake/CMakeLists.txt
@@ -115,6 +115,18 @@ set(GR_HOWTO_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include CACHE INTERNAL ""
set(GR_HOWTO_SWIG_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/swig CACHE INTERNAL "" FORCE)
########################################################################
+# Create uninstall target
+########################################################################
+configure_file(
+ ${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+@ONLY)
+
+add_custom_target(uninstall
+ ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+)
+
+########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include)
@@ -123,4 +135,4 @@ add_subdirectory(swig)
add_subdirectory(python)
add_subdirectory(grc)
add_subdirectory(apps)
-add_subdirectory(docs) \ No newline at end of file
+add_subdirectory(docs)