summaryrefslogtreecommitdiff
path: root/gr-fcd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-fcd/CMakeLists.txt')
-rw-r--r--gr-fcd/CMakeLists.txt22
1 files changed, 16 insertions, 6 deletions
diff --git a/gr-fcd/CMakeLists.txt b/gr-fcd/CMakeLists.txt
index e454c01fa..1185b3a32 100644
--- a/gr-fcd/CMakeLists.txt
+++ b/gr-fcd/CMakeLists.txt
@@ -1,17 +1,17 @@
# Copyright 2012 Free Software Foundation, Inc.
-#
+#
# This file is part of GNU Radio
-#
+#
# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
-#
+#
# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
@@ -44,13 +44,15 @@ else()
ENABLE_GR_CORE
ENABLE_GR_AUDIO
)
-endif()
+endif()
GR_SET_GLOBAL(GR_FCD_INCLUDE_DIRS
${CMAKE_CURRENT_SOURCE_DIR}/lib
${CMAKE_CURRENT_SOURCE_DIR}/include/fcd
)
+SET(GR_PKG_FCD_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/fcd)
+
########################################################################
# Begin conditional configuration
########################################################################
@@ -83,6 +85,13 @@ CPACK_COMPONENT("fcd_python"
DEPENDS "core_python;fcd_runtime"
)
+CPACK_COMPONENT("fcd_examples"
+ GROUP "FCD"
+ DISPLAY_NAME "Examples"
+ DESCRIPTION "Example programs"
+ DEPENDS "fcd_runtime"
+)
+
CPACK_COMPONENT("fcd_swig"
GROUP "FCD"
DISPLAY_NAME "SWIG"
@@ -99,8 +108,9 @@ if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(python)
add_subdirectory(grc)
+ add_subdirectory(examples/grc)
endif(ENABLE_PYTHON)
-add_subdirectory(examples)
+add_subdirectory(examples/c++)
add_subdirectory(doc)
########################################################################