summaryrefslogtreecommitdiff
path: root/gr-digital/hier/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-digital/hier/Makefile.am')
-rw-r--r--gr-digital/hier/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/gr-digital/hier/Makefile.am b/gr-digital/hier/Makefile.am
new file mode 100644
index 000000000..b11b85f77
--- /dev/null
+++ b/gr-digital/hier/Makefile.am
@@ -0,0 +1,40 @@
+#
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(WITH_INCLUDES)
+
+noinst_LTLIBRARIES = libdigital_hier.la
+
+libdigital_hier_la_SOURCES = \
+ digital_gmskmod_bc.cc \
+ digital_cpmmod_bc.cc
+
+grinclude_HEADERS = \
+ digital_gmskmod_bc.h \
+ digital_cpmmod_bc.h
+
+
+swiginclude_HEADERS = \
+ _digital_hier.i \
+ digital_gmskmod_bc.i \
+ digital_cpmmod_bc.i