summaryrefslogtreecommitdiff
path: root/gr-digital/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-digital/examples/CMakeLists.txt')
-rw-r--r--gr-digital/examples/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/gr-digital/examples/CMakeLists.txt b/gr-digital/examples/CMakeLists.txt
index 12fca6009..33d257e59 100644
--- a/gr-digital/examples/CMakeLists.txt
+++ b/gr-digital/examples/CMakeLists.txt
@@ -19,6 +19,7 @@
include(GrPython)
+# Base stuff
GR_PYTHON_INSTALL(PROGRAMS
example_costas.py
example_fll.py
@@ -30,6 +31,7 @@ GR_PYTHON_INSTALL(PROGRAMS
COMPONENT "digital_python"
)
+# Narrowband
GR_PYTHON_INSTALL(PROGRAMS
narrowband/transmit_path.py
narrowband/receive_path.py
@@ -45,6 +47,7 @@ GR_PYTHON_INSTALL(PROGRAMS
COMPONENT "digital_python"
)
+# OFDM
GR_PYTHON_INSTALL(PROGRAMS
ofdm/benchmark_add_channel.py
ofdm/benchmark_rx.py
@@ -58,3 +61,16 @@ GR_PYTHON_INSTALL(PROGRAMS
DESTINATION ${GR_PKG_DIGITAL_EXAMPLES_DIR}/ofdm
COMPONENT "digital_python"
)
+
+# DEMOD
+install(
+ FILES
+ demod/digital_freq_lock.grc
+ demod/mpsk_demod.grc
+ demod/pam_sync.grc
+ demod/pam_timing.grc
+ demod/ber_simulation.grc
+ demod/dpsk_loopback.grc
+ DESTINATION ${GR_PKG_DIGITAL_EXAMPLES_DIR}/demod
+ COMPONENT "digital_python"
+)