summaryrefslogtreecommitdiff
path: root/gr-comedi/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-comedi/src/Makefile.am')
-rw-r--r--gr-comedi/src/Makefile.am22
1 files changed, 9 insertions, 13 deletions
diff --git a/gr-comedi/src/Makefile.am b/gr-comedi/src/Makefile.am
index a55bd175b..47f689adb 100644
--- a/gr-comedi/src/Makefile.am
+++ b/gr-comedi/src/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2005,2008,2009 Free Software Foundation, Inc.
+# Copyright 2005,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -20,8 +20,12 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+TESTS =
+EXTRA_DIST += run_tests.in
+DISTCLEANFILES += run_tests
-EXTRA_DIST = run_tests.in
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
@@ -49,11 +53,8 @@ libgnuradio_comedi_la_LIBADD = \
libgnuradio_comedi_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
-if PYTHON
###################################
-# SWIG Python interface and library
-TESTS = run_tests
-DISTCLEANFILES = run_tests
+# SWIG interfaces and libraries
TOP_SWIG_IFILES = \
comedi.i
@@ -69,11 +70,6 @@ comedi_pythondir_category = \
comedi_la_swig_libadd = \
libgnuradio-comedi.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
+if PYTHON
+TESTS += run_tests
endif