summaryrefslogtreecommitdiff
path: root/gr-comedi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-comedi/CMakeLists.txt')
-rw-r--r--gr-comedi/CMakeLists.txt104
1 files changed, 104 insertions, 0 deletions
diff --git a/gr-comedi/CMakeLists.txt b/gr-comedi/CMakeLists.txt
new file mode 100644
index 000000000..16a930b49
--- /dev/null
+++ b/gr-comedi/CMakeLists.txt
@@ -0,0 +1,104 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup dependencies
+########################################################################
+INCLUDE(GrBoost)
+
+INCLUDE(FindPkgConfig)
+
+PKG_CHECK_MODULES(COMEDI comedilib)
+
+########################################################################
+# Register component
+########################################################################
+INCLUDE(GrComponent)
+GR_REGISTER_COMPONENT("gr-comedi" ENABLE_GR_COMEDI
+ COMEDI_FOUND
+ LINUX #comedi uses linux specific device noces
+ Boost_FOUND
+ ENABLE_GR_CORE_
+)
+
+REMOVE_DEFINITIONS(-fvisibility=hidden) #FIXME until we do symbol visibility
+
+GR_SET_GLOBAL(GR_COMEDI_INCLUDE_DIRS
+ ${CMAKE_CURRENT_SOURCE_DIR}/src
+)
+
+########################################################################
+# Begin conditional configuration
+########################################################################
+IF(ENABLE_GR_COMEDI)
+
+########################################################################
+# Setup CPack components
+########################################################################
+INCLUDE(GrPackage)
+CPACK_SET(CPACK_COMPONENT_GROUP_COMEDI_DESCRIPTION "GNU Radio Comedi Blocks")
+
+CPACK_COMPONENT("comedi_runtime"
+ GROUP "Comedi"
+ DISPLAY_NAME "Runtime"
+ DESCRIPTION "Runtime"
+ DEPENDS "core_runtime"
+)
+
+CPACK_COMPONENT("comedi_devel"
+ GROUP "Comedi"
+ DISPLAY_NAME "Development"
+ DESCRIPTION "C++ headers, package config, import libraries"
+ DEPENDS "core_devel"
+)
+
+CPACK_COMPONENT("comedi_python"
+ GROUP "Comedi"
+ DISPLAY_NAME "Python"
+ DESCRIPTION "Python modules for runtime; GRC xml files"
+ DEPENDS "core_python;comedi_runtime"
+)
+
+CPACK_COMPONENT("comedi_swig"
+ GROUP "Comedi"
+ DISPLAY_NAME "SWIG"
+ DESCRIPTION "SWIG development .i files"
+ DEPENDS "core_swig;comedi_python;comedi_devel"
+)
+
+########################################################################
+# Add subdirectories
+########################################################################
+ADD_SUBDIRECTORY(src)
+
+########################################################################
+# Create Pkg Config File
+########################################################################
+CONFIGURE_FILE(
+ ${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-comedi.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-comedi.pc
+@ONLY)
+
+INSTALL(
+ FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-comedi.pc
+ DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
+ COMPONENT "comedi_devel"
+)
+
+ENDIF(ENABLE_GR_COMEDI)