summaryrefslogtreecommitdiff
path: root/gr-blocks/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-blocks/lib/CMakeLists.txt')
-rw-r--r--gr-blocks/lib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/gr-blocks/lib/CMakeLists.txt b/gr-blocks/lib/CMakeLists.txt
index b06f46675..0b6c89298 100644
--- a/gr-blocks/lib/CMakeLists.txt
+++ b/gr-blocks/lib/CMakeLists.txt
@@ -18,6 +18,11 @@
# Boston, MA 02110-1301, USA.
########################################################################
+# Setup compatibility checks and defines
+########################################################################
+include(${CMAKE_CURRENT_SOURCE_DIR}/ConfigChecks.cmake)
+
+########################################################################
# generate helper scripts to expand templated files
########################################################################
include(GrPython)
@@ -171,6 +176,7 @@ list(APPEND gr_blocks_sources
list(APPEND blocks_libs
gnuradio-core
+ volk
${Boost_LIBRARIES}
${BLOCKS_LIBRARIES}
)