summaryrefslogtreecommitdiff
path: root/gr-audio/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-audio/CMakeLists.txt')
-rw-r--r--gr-audio/CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/gr-audio/CMakeLists.txt b/gr-audio/CMakeLists.txt
index 7038b9b0f..35fd7fc23 100644
--- a/gr-audio/CMakeLists.txt
+++ b/gr-audio/CMakeLists.txt
@@ -1,17 +1,17 @@
# Copyright 2011 Free Software Foundation, Inc.
-#
+#
# This file is part of GNU Radio
-#
+#
# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
-#
+#
# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
@@ -33,6 +33,8 @@ GR_REGISTER_COMPONENT("gr-audio" ENABLE_GR_AUDIO
GR_SET_GLOBAL(GR_AUDIO_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
+SET(GR_PKG_AUDIO_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/audio)
+
########################################################################
# Begin conditional configuration
########################################################################
@@ -65,6 +67,13 @@ CPACK_COMPONENT("audio_python"
DEPENDS "core_python;audio_runtime"
)
+CPACK_COMPONENT("audio_examples"
+ GROUP "Audio"
+ DISPLAY_NAME "Examples"
+ DESCRIPTION "Example programs"
+ DEPENDS "audio_runtime"
+)
+
CPACK_COMPONENT("audio_swig"
GROUP "Audio"
DISPLAY_NAME "SWIG"
@@ -77,12 +86,13 @@ CPACK_COMPONENT("audio_swig"
########################################################################
add_subdirectory(include)
add_subdirectory(lib)
-add_subdirectory(examples/c++)
add_subdirectory(doc)
+add_subdirectory(examples/c++)
if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(grc)
add_subdirectory(examples/python)
+ add_subdirectory(examples/grc)
endif(ENABLE_PYTHON)
########################################################################