summaryrefslogtreecommitdiff
path: root/gr-audio-osx/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-audio-osx/src/Makefile.am')
-rw-r--r--gr-audio-osx/src/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/gr-audio-osx/src/Makefile.am b/gr-audio-osx/src/Makefile.am
index ee9df7765..fce31c9d2 100644
--- a/gr-audio-osx/src/Makefile.am
+++ b/gr-audio-osx/src/Makefile.am
@@ -20,8 +20,11 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
-EXTRA_DIST = run_tests.in
+TESTS =
+EXTRA_DIST += run_tests.in
+DISTCLEANFILES += run_tests
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
@@ -54,11 +57,8 @@ libgnuradio_audio_osx_la_LDFLAGS = \
$(NO_UNDEFINED) \
$(LTVERSIONFLAGS)
-if PYTHON
###################################
-# SWIG Python interface and library
-TESTS = run_tests
-DISTCLEANFILES = run_tests
+# SWIG interfaces and libraries
TOP_SWIG_IFILES = \
audio_osx.i
@@ -74,11 +74,7 @@ audio_osx_pythondir_category = \
audio_osx_la_swig_libadd = \
libgnuradio-audio-osx.la
-include $(top_srcdir)/Makefile.swig
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-endif
+if PYTHON
+TESTS += run_tests
+endif \ No newline at end of file