summaryrefslogtreecommitdiff
path: root/gr-audio-jack/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-audio-jack/src/Makefile.am')
-rw-r--r--gr-audio-jack/src/Makefile.am75
1 files changed, 0 insertions, 75 deletions
diff --git a/gr-audio-jack/src/Makefile.am b/gr-audio-jack/src/Makefile.am
deleted file mode 100644
index 9a0c8b9be..000000000
--- a/gr-audio-jack/src/Makefile.am
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Copyright 2005,2008,2009,2010 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-#
-
-include $(top_srcdir)/Makefile.common
-include $(top_srcdir)/Makefile.swig
-
-TESTS =
-EXTRA_DIST += run_tests.in
-DISTCLEANFILES += run_tests
-
-# C/C++ headers get installed in ${prefix}/include/gnuradio
-grinclude_HEADERS = \
- audio_jack_sink.h \
- audio_jack_source.h
-
-noinst_HEADERS = \
- gri_jack.h
-
-lib_LTLIBRARIES = libgnuradio-audio-jack.la
-
-libgnuradio_audio_jack_la_SOURCES = \
- audio_jack_sink.cc \
- audio_jack_source.cc \
- gri_jack.cc
-
-libgnuradio_audio_jack_la_LIBADD = \
- $(GNURADIO_CORE_LA) \
- $(JACK_LIBS)
-
-libgnuradio_audio_jack_la_LDFLAGS = $(NO_UNDEFINED) $(LTVERSIONFLAGS)
-
-noinst_PYTHON = \
- qa_jack.py
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) $(WITH_INCLUDES)
-
-###################################
-# SWIG interfaces and libraries
-
-TOP_SWIG_IFILES = \
- audio_jack.i
-
-# Install so that they end up available as:
-# import gnuradio.audio_jack
-# This ends up at:
-# ${prefix}/lib/python${python_version}/site-packages/gnuradio
-audio_jack_pythondir_category = \
- gnuradio
-
-# additional libraries for linking with the SWIG-generated library
-audio_jack_la_swig_libadd = \
- libgnuradio-audio-jack.la
-
-
-if PYTHON
-TESTS += run_tests
-endif