summaryrefslogtreecommitdiff
path: root/gr-atsc/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gr-atsc/src/lib/Makefile.am')
-rw-r--r--gr-atsc/src/lib/Makefile.am22
1 files changed, 8 insertions, 14 deletions
diff --git a/gr-atsc/src/lib/Makefile.am b/gr-atsc/src/lib/Makefile.am
index bf9c6626a..b1bda90ff 100644
--- a/gr-atsc/src/lib/Makefile.am
+++ b/gr-atsc/src/lib/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2001,2004,2005,2006,2008,2009 Free Software Foundation, Inc.
+# Copyright 2001,2004,2005,2006,2008,2009,2010 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -20,11 +20,12 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS) \
$(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
-EXTRA_DIST = \
+EXTRA_DIST += \
atsci_viterbi_gen.cc \
gen_encoder.py \
qa_atsci_trellis_encoder_t1_input.dat \
@@ -84,9 +85,10 @@ libgnuradio_atsc_la_SOURCES = \
create_atsci_equalizer.cc \
create_atsci_fs_checker.cc \
create_atsci_fs_correlator.cc \
- plinfo.cc
+ plinfo.cc
+
-BUILT_SOURCES = \
+BUILT_SOURCES += \
atsci_viterbi_mux.cc
libgnuradio_atsc_la_LIBADD = \
@@ -210,12 +212,11 @@ test_atsci_LDADD = \
# Cleanup
# ------------------------------------------------------------------------
-CLEANFILES = atsci_viterbi_mux.cc atsci_viterbi_gen$(EXEEXT)
+CLEANFILES += atsci_viterbi_mux.cc atsci_viterbi_gen$(EXEEXT)
-if PYTHON
# ------------------------------------------------------------------------
# This is the swig-ish part of the Makefile.
-# It builds the atsc module which we'll load into python
+# It builds the atsc modules which we'll load into python or guile
# ------------------------------------------------------------------------
TOP_SWIG_IFILES = \
@@ -232,11 +233,4 @@ atsc_pythondir_category = \
atsc_la_swig_libadd = \
libgnuradio-atsc.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES += $(swig_built_sources)
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-endif