summaryrefslogtreecommitdiff
path: root/gnuradio-core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-core/CMakeLists.txt')
-rw-r--r--gnuradio-core/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnuradio-core/CMakeLists.txt b/gnuradio-core/CMakeLists.txt
index 101f4c3a3..022710844 100644
--- a/gnuradio-core/CMakeLists.txt
+++ b/gnuradio-core/CMakeLists.txt
@@ -1,17 +1,17 @@
# Copyright 2010-2011 Free Software Foundation, Inc.
-#
+#
# This file is part of GNU Radio
-#
+#
# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
-#
+#
# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
@@ -22,8 +22,6 @@
########################################################################
include(GrBoost)
-find_package(GSL)
-
find_package(FFTW3f)
include(GrPython) #used for code generation
@@ -41,7 +39,6 @@ GR_REGISTER_COMPONENT("gnuradio-core" ENABLE_GR_CORE
ENABLE_GRUEL
ENABLE_VOLK
Boost_FOUND
- GSL_FOUND
FFTW3F_FOUND
PYTHONINTERP_FOUND
)
@@ -126,6 +123,7 @@ endif(ENABLE_TESTING)
if(ENABLE_PYTHON)
add_subdirectory(src/lib/swig)
add_subdirectory(src/python/gnuradio)
+ add_subdirectory(src/examples)
endif(ENABLE_PYTHON)
########################################################################