summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control21
-rwxr-xr-xdebian/install-build-deps.sh16
-rwxr-xr-xdebian/rules10
4 files changed, 27 insertions, 22 deletions
diff --git a/debian/changelog b/debian/changelog
index acccb6136..a2e46ce51 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-gnuradio (3.0.svn) unstable; urgency=low
+gnuradio (3.0~svn) unstable; urgency=low
* add/split packages to cover entire GNU Radio distribution
* fix build failure with gcc-4.3 by adding a #include, closes: #420896
diff --git a/debian/control b/debian/control
index c6a0644da..25a4ad760 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,7 @@ Section: comm
Priority: optional
Maintainer: Bdale Garbee <bdale@gag.com>
Build-Conflicts: automake1.8, automake1.9
-Build-Depends: debhelper (>= 5.0.37.2), autotools-dev, doxygen, fftw3-dev, libasound2-dev, libboost-dev, libcppunit-dev, libjack0.100.0-dev, libsdl1.2-dev, portaudio19-dev, libtool, libusb-dev, pkg-config, python, python-all-dev, python-central (>= 0.5), python-numpy, python-wxgtk2.6, sdcc, swig, xmlto
-Build-Depends-Indep: python-all-dev
+Build-Depends: debhelper (>= 5.0.37.2), autotools-dev, doxygen, fftw3-dev | libfftw3-dev, libasound2-dev, libboost-dev, libcppunit-dev, libjack0.100.0-dev, libsdl1.2-dev, portaudio19-dev, libtool, libusb-dev, pkg-config, python, python-all-dev, python-central (>= 0.5), python-numpy, python-wxgtk2.6, sdcc, swig, xmlto
Standards-Version: 3.7.2
XS-Python-Version: >= 2.3
@@ -19,7 +18,7 @@ Description: GNU Radio Omnithreads Abstraction Library
Package: libgnuradio-omnithread0-dev
Section: libdevel
Architecture: any
-Depends: libgnuradio-omnithread0c2a (= ${Source-Version})
+Depends: libgnuradio-omnithread0c2a (= ${binary:Version})
Description: GNU Radio Omnithreads Abstraction Library
This package is a fork of the omniORB-4.0.1 threading library
for use with GNU Radio.
@@ -38,7 +37,7 @@ Description: GNU Radio Polymorphic Type Library
Package: libpmt0-dev
Section: libdevel
Architecture: any
-Depends: libpmt0c2a (= ${Source-Version}), libgnuradio-omnithread0-dev, libboost-dev
+Depends: libpmt0c2a (= ${binary:Version}), libgnuradio-omnithread0-dev, libboost-dev
Description: GNU Radio Polymorphic Type Library
This package implements polymorphic types. These are similar
to lisp or python data objects, and implement transparent
@@ -56,7 +55,7 @@ Description: GNU Radio Message Block Library
Package: libmblock0-dev
Section: libdevel
Architecture: any
-Depends: libmblock0c2a (= ${Source-Version}), libgnuradio-omnithread0-dev, libpmt0-dev
+Depends: libmblock0c2a (= ${binary:Version}), libgnuradio-omnithread0-dev, libpmt0-dev
Description: GNU Radio Message Block Library
This package provides the GNU Radio message block library.
.
@@ -75,7 +74,7 @@ Description: GNU Radio Core Library
Package: libgnuradio-core0-dev
Section: libdevel
Architecture: any
-Depends: libgnuradio-core0c2a (= ${Source-Version}), libgnuradio-omnithread0-dev, libboost-dev, fftw3-dev
+Depends: libgnuradio-core0c2a (= ${binary:Version}), libgnuradio-omnithread0-dev, libboost-dev, fftw3-dev | libfftw3-dev
Description: Software Defined Radio
This package contains the core GNU Radio libraries.
.
@@ -231,7 +230,7 @@ Section: comm
Architecture: all
Depends: gnuradio-doc, python-gnuradio, gnuradio-examples
Suggests: usrp
-Descripton: GNU Software Defined Radio
+Description: GNU Software Defined Radio
This is a virtual package that depends the entire GNU Radio collection of
components. If you are using a USRP, you should also install the usrp package.
@@ -241,8 +240,8 @@ Architecture: all
Depends: libgnuradio-core0-dev, libgnuradio-omnithread0-dev, libmblock0-dev, libpmt0-dev
Description: Development headers for GNU Radio C++ development
This is a virtual package that depends on all the development header packages
- for the various GNU Radio components. It is only needed if you intend to develop
- custom GNU Radio signal processing blocks in C++.
+ for the various GNU Radio components. It is only needed if you intend to
+ develop custom GNU Radio signal processing blocks in C++.
Package: usrp-firmware
Section: contrib/comm
@@ -279,7 +278,7 @@ Description: Client side library for the USRP
Package: libusrp0-dev
Section: contrib/libdevel
Architecture: any
-Depends: libusrp0c2a (= ${Source-Version}), libusb-dev
+Depends: libusrp0c2a (= ${binary:Version}), libusb-dev
Description: Client side library for the USRP
The Universal Software Radio Peripheral (USRP) is an USB-connected,
low-cost and open board. It features four high-speed analog-to-digital
@@ -304,7 +303,7 @@ Description: Client side library for the USRP with in-band signaling
Package: libusrp-inband0-dev
Section: contrib/libdevel
Architecture: any
-Depends: libusrp-inband0c2a (= ${Source-Version}), libusrp0-dev
+Depends: libusrp-inband0c2a (= ${binary:Version}), libusrp0-dev
Description: Client side library for the USRP with in-band signaling
The package is an alternative C++ interface to the USRP that implements
an experimental in-band signaling method across the USB.
diff --git a/debian/install-build-deps.sh b/debian/install-build-deps.sh
new file mode 100755
index 000000000..3dbbf8b8b
--- /dev/null
+++ b/debian/install-build-deps.sh
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+ISSUE=`cut -f 1 -d ' ' /etc/issue`
+
+if test "$ISSUE" = "Ubuntu"; then
+ FFTW3DEV=fftw3-dev
+else
+ FFTW3DEV=libfftw3-dev
+fi
+
+sudo apt-get install \
+ autotools-dev doxygen $FFTW3DEV libasound2-dev \
+ libboost-dev libcppunit-dev libjack0.100.0-dev libsdl1.2-dev \
+ portaudio19-dev libtool libusb-dev pkg-config python python-all-dev \
+ python-central python-numpy python-wxgtk2.6 sdcc swig xmlto
+
diff --git a/debian/rules b/debian/rules
index 92d5bd65a..b9c8ac622 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,4 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets by Bill Allombert 2001
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1