summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 91bbe755a..fe32ccf5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,7 +148,20 @@ AC_ARG_ENABLE([python],
esac],
[enable_python=yes]
)
+
+AC_ARG_ENABLE([guile],
+ [AS_HELP_STRING([--enable-guile],
+ [generate SWIG/Guile components (default is yes)])],
+ [case "${enableval}" in
+ yes) enable_guile=yes ;;
+ no) enable_guile=no ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-guile]) ;;
+ esac],
+ [enable_guile=no]
+)
+
AM_CONDITIONAL([PYTHON], [test x$enable_python = xyes])
+AM_CONDITIONAL([GUILE], [test x$enable_guile = xyes])
AC_CHECK_PROG([XMLTO],[xmlto],[yes],[])
AM_CONDITIONAL([HAS_XMLTO], [test x$XMLTO = xyes])
@@ -362,6 +375,7 @@ GRC_GR_COMEDI
GRC_GR_CVSD_VOCODER
GRC_GR_GPIO
GRC_GR_GSM_FR_VOCODER
+GRC_GR_GUILE
GRC_GR_NOAA
GRC_GR_PAGER
GRC_GR_RADAR_MONO
@@ -371,7 +385,7 @@ GRC_GR_VIDEO_SDL
GRC_GR_WXGUI
GRC_GR_QTGUI
GRC_GR_SOUNDER dnl this must come after GRC_USRP
-GRC_GR_UTILS dnl this must come after GRC_GR_WXGUI
+GRC_GR_UTILS dnl this must come after GRC_GR_WXGUI
GRC_GNURADIO_EXAMPLES dnl must come after all GRC_GR_*
GRC_GRC
GRC_GR_UHD
@@ -402,7 +416,8 @@ AC_SUBST(with_LIBDIRPATH)
AC_CONFIG_FILES([\
Makefile \
run_tests.sh \
- config/Makefile \
+ setup_guile_test_env \
+ config/Makefile
])
dnl run_tests.sh is created from run_tests.sh.in . Make it executable.