summaryrefslogtreecommitdiff
path: root/usrp/host/apps/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-06 04:31:17 +0000
committerjcorgan2006-08-06 04:31:17 +0000
commit951966ca64fc1ddd24889f6318c8c8794657cfba (patch)
tree610eb170a28db4cc195354594ad510bd7423593d /usrp/host/apps/Makefile.am
parentdb1b2f7c85600ffd108bd69a381505e0e7223a8a (diff)
downloadgnuradio-951966ca64fc1ddd24889f6318c8c8794657cfba.tar.gz
gnuradio-951966ca64fc1ddd24889f6318c8c8794657cfba.tar.bz2
gnuradio-951966ca64fc1ddd24889f6318c8c8794657cfba.zip
Partial fix for ticket 10 merged into trunk from
branches/developers/jcorgan/ticket-10 As of this merge the trunk and the above branch are identical. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3182 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'usrp/host/apps/Makefile.am')
-rw-r--r--usrp/host/apps/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/usrp/host/apps/Makefile.am b/usrp/host/apps/Makefile.am
index b08e32527..87a3774a0 100644
--- a/usrp/host/apps/Makefile.am
+++ b/usrp/host/apps/Makefile.am
@@ -19,7 +19,11 @@
# Boston, MA 02111-1307, USA.
#
-INCLUDES = -I../lib -I$(top_srcdir)/usrp/firmware/include
+include $(top_srcdir)/Makefile.common
+
+INCLUDES = $(USRP_INCLUDES)
+
+USRP_LIB = $(top_builddir)/usrp/host/lib/libusrp.la
bin_PROGRAMS = \
usrper \
@@ -41,13 +45,13 @@ noinst_PYTHON = \
check_order_quickly_SOURCES = check_order_quickly.cc
test_usrp_standard_rx_SOURCES = test_usrp_standard_rx.cc time_stuff.c
-test_usrp_standard_rx_LDADD = $(top_builddir)/usrp/host/lib/libusrp.la
+test_usrp_standard_rx_LDADD = $(USRP_LIB)
test_usrp_standard_tx_SOURCES = test_usrp_standard_tx.cc time_stuff.c
-test_usrp_standard_tx_LDADD = $(top_builddir)/usrp/host/lib/libusrp.la
+test_usrp_standard_tx_LDADD = $(USRP_LIB)
usrper_SOURCES = usrper.cc
-usrper_LDADD = $(top_builddir)/usrp/host/lib/libusrp.la
+usrper_LDADD = $(USRP_LIB)
usrp_cal_dc_offset_SOURCES = usrp_cal_dc_offset.cc
-usrp_cal_dc_offset_LDADD = $(top_builddir)/usrp/host/lib/libusrp.la
+usrp_cal_dc_offset_LDADD = $(USRP_LIB)