summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/swig/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye2010-11-15 19:08:28 -0700
committerRob Savoye2010-11-15 19:08:28 -0700
commitc8835c285c6abbc334701238f53f87f93e6f125a (patch)
tree56f669470eba5086e20b2a8fb623ac58c62a2de5 /gr-howto-write-a-block/swig/Makefile.am
parent4b3d08cca3095c180d2d2bcf24de907c1afa9bfc (diff)
downloadgnuradio-c8835c285c6abbc334701238f53f87f93e6f125a.tar.gz
gnuradio-c8835c285c6abbc334701238f53f87f93e6f125a.tar.bz2
gnuradio-c8835c285c6abbc334701238f53f87f93e6f125a.zip
make howto build the new way
Diffstat (limited to 'gr-howto-write-a-block/swig/Makefile.am')
-rw-r--r--gr-howto-write-a-block/swig/Makefile.am35
1 files changed, 24 insertions, 11 deletions
diff --git a/gr-howto-write-a-block/swig/Makefile.am b/gr-howto-write-a-block/swig/Makefile.am
index 4737ad619..a57834683 100644
--- a/gr-howto-write-a-block/swig/Makefile.am
+++ b/gr-howto-write-a-block/swig/Makefile.am
@@ -20,8 +20,19 @@
#
include $(top_srcdir)/Makefile.common
+include $(top_srcdir)/Makefile.swig
+
+# add some of the variables generated inside the Makefile.swig.gen
+BUILT_SOURCES = $(swig_built_sources)
+
+CLEANFILES = python/*.cc python/*.h python/*.d
+if GUILE
+CLEANFILES += guile/*.cc gnuradio/*.scm guile/*.d
+endif
-AM_CPPFLAGS += -I$(top_srcdir)/lib
+AM_CPPFLAGS += -I$(top_srcdir)/lib
+
+swig_built_sources =
if PYTHON
###################################
@@ -34,21 +45,23 @@ TOP_SWIG_IFILES = \
# import howto
# This ends up at:
# ${prefix}/lib/python${python_version}/site-packages/$(modname)
-
howto_la_swig_libadd = \
$(top_builddir)/lib/libgnuradio-howto.la
-include $(top_srcdir)/Makefile.swig
-
-# add some of the variables generated inside the Makefile.swig.gen
-BUILT_SOURCES = $(swig_built_sources)
-
-# Do not distribute the output of SWIG
-no_dist_files = $(swig_built_sources)
-
# additional SWIG files to be installed
-howto_swiginclude_headers = \
+aqhowto_swiginclude_headers = \
howto_square_ff.i \
howto_square2_ff.i
+PYTHON_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(subst .i,.py,$(HFILE)))
+swig_built_sources += $(PYTHON_GEN)
endif
+
+if GUILE
+GUILE_GEN = $(foreach HFILE,$(TOP_SWIG_IFILES), $(patsubst %.i,gnuradio/%.scm,$(HFILE)))
+swig_built_sources += $(GUILE_GEN)
+endif
+
+# Do not distribute the output of SWIG
+no_dist_files = $(swig_built_sources)
+