summaryrefslogtreecommitdiff
path: root/gr-audio-alsa/src/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2006-08-03 04:51:51 +0000
committerjcorgan2006-08-03 04:51:51 +0000
commit5d69a524f81f234b3fbc41d49ba18d6f6886baba (patch)
treeb71312bf7f1e8d10fef0f3ac6f28784065e73e72 /gr-audio-alsa/src/Makefile.am
downloadgnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.gz
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.tar.bz2
gnuradio-5d69a524f81f234b3fbc41d49ba18d6f6886baba.zip
Houston, we have a trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3122 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gr-audio-alsa/src/Makefile.am')
-rw-r--r--gr-audio-alsa/src/Makefile.am91
1 files changed, 91 insertions, 0 deletions
diff --git a/gr-audio-alsa/src/Makefile.am b/gr-audio-alsa/src/Makefile.am
new file mode 100644
index 000000000..e06fef9ae
--- /dev/null
+++ b/gr-audio-alsa/src/Makefile.am
@@ -0,0 +1,91 @@
+#
+# Copyright 2004 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+# Install this stuff so that it ends up as the gnuradio.audio_alsa module
+# This usually ends up at:
+# ${prefix}/lib/python${python_version}/site-packages/gnuradio
+
+ourpythondir = $(grpythondir)
+ourlibdir = $(grpyexecdir)
+
+LIBS += $(GNURADIO_CORE_LIBS)
+
+EXTRA_DIST = run_tests.in
+
+TESTS = run_tests
+
+LOCAL_IFILES = \
+ audio_alsa.i
+
+NON_LOCAL_IFILES = \
+ $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
+
+ALL_IFILES = \
+ $(LOCAL_IFILES) \
+ $(NON_LOCAL_IFILES)
+
+BUILT_SOURCES = \
+ audio_alsa.cc \
+ audio_alsa.py
+
+ourpython_PYTHON = \
+ audio_alsa.py
+
+INCLUDES = $(STD_DEFINES_AND_INCLUDES) $(PYTHON_CPPFLAGS)
+
+SWIGPYTHONARGS = $(SWIGPYTHONFLAGS) $(STD_DEFINES_AND_INCLUDES)
+
+ourlib_LTLIBRARIES = _audio_alsa.la
+
+_audio_alsa_la_SOURCES = \
+ audio_alsa.cc \
+ audio_alsa_sink.cc \
+ audio_alsa_source.cc \
+ gri_alsa.cc
+
+grinclude_HEADERS = \
+ audio_alsa_sink.h \
+ audio_alsa_source.h
+
+noinst_HEADERS = \
+ gri_alsa.h
+
+
+swiginclude_HEADERS = \
+ $(LOCAL_IFILES)
+
+_audio_alsa_la_LIBADD = \
+ $(PYTHON_LDFLAGS) \
+ -lstdc++
+
+_audio_alsa_la_LDFLAGS = $(NO_UNDEFINED) -module -avoid-version
+
+audio_alsa.cc audio_alsa.py: audio_alsa.i $(NON_LOCAL_IFILES)
+ $(SWIG) $(SWIGPYTHONARGS) -module audio_alsa -o audio_alsa.cc $<
+
+
+noinst_PYTHON = \
+ qa_alsa.py
+
+MOSTLYCLEANFILES = \
+ $(BUILT_SOURCES) *~ *.pyc