summaryrefslogtreecommitdiff
path: root/Windows/spice/tests/xspice/digital/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Windows/spice/tests/xspice/digital/Makefile.am')
-rw-r--r--Windows/spice/tests/xspice/digital/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Windows/spice/tests/xspice/digital/Makefile.am b/Windows/spice/tests/xspice/digital/Makefile.am
new file mode 100644
index 00000000..c89536ee
--- /dev/null
+++ b/Windows/spice/tests/xspice/digital/Makefile.am
@@ -0,0 +1,18 @@
+## Process this file with automake to produce Makefile.in
+
+TESTS = \
+ d_ram.cir \
+ d_source.cir \
+ d_state.cir
+
+TESTS_ENVIRONMENT = ngspice_vpath=$(srcdir) SPICE_SCRIPTS=. $(SHELL) $(top_srcdir)/tests/bin/check.sh "$(top_builddir)/src/ngspice -r foobaz"
+
+EXTRA_DIST = \
+ d_ram-stimulus.txt \
+ d_source-stimulus.txt \
+ d_state-stimulus.txt \
+ d_state-updn.txt \
+ $(TESTS) \
+ $(TESTS:.cir=.out)
+
+MAINTAINERCLEANFILES = Makefile.in