summaryrefslogtreecommitdiff
path: root/Windows/sandpiper-saas.spec
diff options
context:
space:
mode:
authorrahulp132022-02-28 14:48:29 +0530
committerrahulp132022-02-28 14:48:29 +0530
commit4b38b9eeab8b5fdd4e9744fc2057a6003b4d144d (patch)
tree542ac2b5417789f39179bb20e0e9201563058277 /Windows/sandpiper-saas.spec
parentd8a24d37f59ecd67ecf310b04e9e2b6d90c5d50d (diff)
downloadeSim-4b38b9eeab8b5fdd4e9744fc2057a6003b4d144d.tar.gz
eSim-4b38b9eeab8b5fdd4e9744fc2057a6003b4d144d.tar.bz2
eSim-4b38b9eeab8b5fdd4e9744fc2057a6003b4d144d.zip
Added Makerchip packaging instructions
Diffstat (limited to 'Windows/sandpiper-saas.spec')
-rwxr-xr-xWindows/sandpiper-saas.spec40
1 files changed, 40 insertions, 0 deletions
diff --git a/Windows/sandpiper-saas.spec b/Windows/sandpiper-saas.spec
new file mode 100755
index 00000000..a84da033
--- /dev/null
+++ b/Windows/sandpiper-saas.spec
@@ -0,0 +1,40 @@
+# -*- mode: python ; coding: utf-8 -*-
+
+
+block_cipher = None
+
+
+a = Analysis(['sandpiper\\__main__.py'],
+ pathex=[],
+ binaries=[],
+ datas=[('LICENSE.md', '.')],
+ hiddenimports=[],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False)
+pyz = PYZ(a.pure, a.zipped_data,
+ cipher=block_cipher)
+
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name='sandpiper-saas',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=False,
+ disable_windowed_traceback=False,
+ target_arch=None,
+ codesign_identity=None,
+ entitlements_file=None )