summaryrefslogtreecommitdiff
path: root/ldmicro/CMakeLists.txt
diff options
context:
space:
mode:
authorNatsuDrag92018-06-06 16:04:50 +0530
committerGitHub2018-06-06 16:04:50 +0530
commit8edcd030cb7c3716e4da4a1aceb4f692ffa8bb64 (patch)
tree411f4316499406d225c50fb64da5bf48240983ab /ldmicro/CMakeLists.txt
parent003741ef327ab000986e6c5a3bc8ff058c171efc (diff)
parent2307d7aa409430506eeaed03633c8c31dd7f4ac1 (diff)
downloadLDMicroGtk-8edcd030cb7c3716e4da4a1aceb4f692ffa8bb64.tar.gz
LDMicroGtk-8edcd030cb7c3716e4da4a1aceb4f692ffa8bb64.tar.bz2
LDMicroGtk-8edcd030cb7c3716e4da4a1aceb4f692ffa8bb64.zip
Merge pull request #6 from akshay-c/GUI_port
Gui port pull
Diffstat (limited to 'ldmicro/CMakeLists.txt')
-rw-r--r--ldmicro/CMakeLists.txt41
1 files changed, 35 insertions, 6 deletions
diff --git a/ldmicro/CMakeLists.txt b/ldmicro/CMakeLists.txt
index 5486fec..8c568fa 100644
--- a/ldmicro/CMakeLists.txt
+++ b/ldmicro/CMakeLists.txt
@@ -60,10 +60,39 @@ IF(UNIX)
## Dummy compile and install to test linuxUI
## to compile LDmicro uncomment the below 2 line2
- #add_executable (LDMicro ldmicro.cpp)# miscutil.cpp draw_outputdev.cpp)
- # install (TARGETS LDMicro DESTINATION bin)
- add_executable (testMain testMain.cpp)
- target_link_libraries (testMain LinuxUI)
- target_link_libraries (testMain FreezeLD)
- install (TARGETS testMain DESTINATION bin)
+ set (COMPILE_CPP_SOURCES #naminglist.cpp
+ arduino.cpp
+ avr.cpp
+ pic16.cpp
+ interpreted.cpp
+ ansic.cpp
+ compilecommon.cpp
+ intcode.cpp
+ lang.cpp
+ miscutil.cpp
+ iolist.cpp
+ #confdialog.cpp
+ #lutdialog.cpp
+ #resetdialog.cpp
+ #simpledialog.cpp
+ #coildialog.cpp
+ #contactsdialog.cpp
+ #commentdialog.cpp
+ #simulate.cpp
+ loadsave.cpp
+ undoredo.cpp
+ circuit.cpp
+ draw_outputdev.cpp
+ #draw.cpp
+ schematic.cpp
+ #helpdialog.cpp
+ maincontrols.cpp
+ ldmicro.cpp)
+
+ add_executable (LDMicro ${COMPILE_CPP_SOURCES})
+ install (TARGETS LDMicro DESTINATION bin)
+ target_link_libraries (LDMicro LinuxUI)
+ target_link_libraries (LDMicro FreezeLD)
+ #add_executable (testMain testMain.cpp)
+ #install (TARGETS testMain DESTINATION bin)
ENDIF(UNIX)