summaryrefslogtreecommitdiff
path: root/polygon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'polygon/CMakeLists.txt')
-rw-r--r--polygon/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/polygon/CMakeLists.txt b/polygon/CMakeLists.txt
new file mode 100644
index 0000000..2f09cbe
--- /dev/null
+++ b/polygon/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+include_directories(BEFORE ${INC_BEFORE})
+include_directories(
+ ${INC_AFTER}
+ )
+
+set(POLYGON_SRCS
+ math_for_graphics.cpp
+ PolyLine.cpp
+ polygon_test_point_inside.cpp
+ clipper.cpp
+)
+
+add_library(polygon STATIC ${POLYGON_SRCS})
+
+add_dependencies( polygon lib-dependencies )
+