summaryrefslogtreecommitdiff
path: root/pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorsaurabhb172020-02-26 16:01:28 +0530
committerGitHub2020-02-26 16:01:28 +0530
commitd51317f0193609fb43e932730d78aa86a4984083 (patch)
tree6acee185a4dc19113fcbf0f9a3d6941085dedaf7 /pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt
parent0db48f6533517ecebfd9f0693f89deca28408b76 (diff)
parent886d9cb772e81d2e5262284bc3082664f084337f (diff)
downloadKiCad-eSim-d51317f0193609fb43e932730d78aa86a4984083.tar.gz
KiCad-eSim-d51317f0193609fb43e932730d78aa86a4984083.tar.bz2
KiCad-eSim-d51317f0193609fb43e932730d78aa86a4984083.zip
Merge pull request #2 from FOSSEE/develop
Develop
Diffstat (limited to 'pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt')
-rw-r--r--pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt b/pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt
new file mode 100644
index 0000000..11e60de
--- /dev/null
+++ b/pcbnew/pcad2kicadpcb_plugin/CMakeLists.txt
@@ -0,0 +1,32 @@
+
+# Sources for the pcbnew PLUGIN called PCAD_PLUGIN
+
+# This CMakeLists.txt is included from pcbnew, so we are inheriting its include_directories(),
+# simply add the current source dir to inherited include_directories() for sources in here only.
+include_directories( . )
+
+
+set( PCAD2PCBNEW_SRCS
+ pcad2kicad_common.cpp
+ pcad_plugin.cpp
+ pcb.cpp
+ pcb_arc.cpp
+ pcb_component.cpp
+ pcb_copper_pour.cpp
+ pcb_cutout.cpp
+ pcb_keepout.cpp
+ pcb_line.cpp
+ pcb_module.cpp
+ pcb_net.cpp
+ pcb_pad.cpp
+ pcb_pad_shape.cpp
+ pcb_plane.cpp
+ pcb_polygon.cpp
+ pcb_text.cpp
+ pcb_via.cpp
+ pcb_via_shape.cpp
+ s_expr_loader.cpp
+ )
+
+add_library( pcad2kicadpcb STATIC ${PCAD2PCBNEW_SRCS} )
+add_dependencies( pcad2kicadpcb pcbcommon )